当前位置: 安全纵横 > 安全公告

Unix平台Apache mod_proxy_http模块超时处理信息泄露漏洞

更新日期:2010-08-06

影响版本:

Apache 2.2.9

漏洞描述:

BUGTRAQ ID: 42102
CVE(CAN) ID: CVE-2010-2791
Apache HTTP Server是一款流行的Web服务器。
Apache HTTP Server的mod_proxy_http模块中的mod_proxy_http.c文件没有正确地检测超时,在某些超时情况下服务器可能返回属于其他用户的响应,
导致泄漏敏感信息。仅有可触发使用代理worker池的配置才受影响。
该漏洞与CVE-2010-2068中所述漏洞相同,但影响的是Unix系统上的httpd。

参考

http://permalink.gmane.org/gmane.comp.security.oss.general/3243

安恒安全建议:
建议使用明御WEB应用防火墙可以避免此漏洞产生的危害。

厂商补丁:

Apache Group

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://svn.apache.org/viewvc?view=revision&revision=699841