当前位置: 安全纵横 > 安全公告

NetBSD pam_unix模块非授权可更改root用户口令漏洞

受影响系统:
NetBSD NetBSD 5.0
NetBSD NetBSD 4.0.1
NetBSD NetBSD 4.0
描述:
NetBSD是一款免费开放源代码的UNIX性质的操作系统。
NetBSD所提供的pam_unix认证模块没有正确地验证执行口令更改的用户,通过认证的非特权用户如果知道了旧的root口令就可以更改该口令。通常认证为root仅限于被称为wheel组的成员,以限制泄露root口令所造成的影响。因此,能够更改root口令应仅限于认证为root的用户。

厂商补丁:
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.netbsd.org/Security/