当前位置: 安全纵横 > 安全公告

cPanel文件管理器文件名HTML注入漏洞

受影响系统:
cPanel cPanel 11.24.4-CURRENT

描述:
cPanel是基于web的工具,用于自动化控制网站和服务器。
Cpanel内嵌有两个文件管理器,分别为标准和旧式文件管理器。这两个文件管理器在处理文件名时存在跨站脚本漏洞,远程攻击者可以通过创建特制的文件名注入并执行脚本。
对于旧式文件管理器,只要查看了文件列表就可以执行攻击者的代码;对于标准文件管理器,文件列表经过转义,但如果用户对恶意文件执行了删除、拷贝、移动、重新命名等任务的话,仍可能执行注入的脚本。
由于文件名中禁用斜线字符,因此攻击者无法直接使用<script>标签加载脚本。为了摆脱这个限制,攻击者可以通过<img>标签onError属性注入脚本并将src属性设置为空字符串来强制触发出错事件。通过<img>标签注入的脚本生成<script>标签,使用document.write()函数执行外部脚本。

厂商补丁:

目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:http://www.cpanel.net