当前位置: 安全纵横 > 安全公告

IBM AIX多个本地溢出及权限提升漏洞

受影响系统:
IBM AIX 6.1.2
IBM AIX 6.1.1
IBM AIX 6.1
描述:
IBM AIX是一款商业性质的UNIX操作系统。
IBM AIX中的多个安全漏洞可能允许本地攻击者触发缓冲区溢出,以提升的权限执行任意操作。
1) /usr/sbin/ndp setuid root程序中存在缓冲区溢出。成功利用这个漏洞要求在运行netcd守护程序。

2) 特权的/usr/sbin/autoconf6命令中存在缓冲区溢出。成功利用这个漏洞要求在使用RBAC且攻击者拥有aix.network.config.tcpip授权。

3) 如果/etc/qconfig定义漏洞打印队列的话,特权/usr/bin/enq命令中的错误可能导致删除任意文件。

4) 特权/usr/bin/crontab命令中的错误可能导致权限提升。成功利用这个漏洞要求获得了aix.system.config.cron授权。

临时解决方法:

a) 停止netcd守护程序并从/usr/sbin/ndp删除setuid和setgid位:

stopsrc -s netcd
chmod 555 /usr/sbin/ndp

b) 删除用户角色的aix.network.config.tcpip和aix.system.config.cron授权。
c) 从/usr/bin/enq删除setuid和setgid位:

chmod 555 /usr/bin/enq

厂商补丁:
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载http://aix.software.ibm.com/aix/efixes/security/aix61_fix.tar